Veröffentlicht Fri, 23 Aug 2019 12:43:21 GMT von Steve Shriver Application Specialist
I’m getting time out errors and very slow response using
an SQL connection for a multi-column select list,
 to the large number of records in the view.

what is the best fastest way to access a large table?
Sql statements are enabled.

thanks 
 
Veröffentlicht Fri, 23 Aug 2019 16:38:44 GMT von Craig Heintz GSME
You may want to consider that this is a VIEW and will be subject to the performance of the SQL server that the view is coming from.
Many times a separate remote SQL server for say accounting is used, it is busy, where the task queue is buried in requests and that view takes a while to populate or the memory or cpu is peaking on that server.  This will cause the VIEW to be slow.

Sometimes modifying the view to have more distilled results of what it returns is the fix.  Sometimes fixing the remote servers resources is the fix.

Also, if you can run the VIEW from SQL Mgnt Studio to see how long it takes to load you may find that it is just slow.  This is nothign to do with DocuWare.

 
Veröffentlicht Wed, 28 Aug 2019 19:34:46 GMT von Steve Shriver Application Specialist
What is the syntax required if we use the SQL Statement option for the select list? Is it only the WHERE clause or a complete query? In which case I am wondering if we could use SELECT TOP 10 as part of the query as the results are not returned until the first field is entered.

Many thanks, 
Veröffentlicht Thu, 29 Aug 2019 19:42:29 GMT von Steve Shriver Application Specialist

I have tried a SELECT DISTINCT... SQL statement in hopes of reducing the number of records in the result set. Unfortunately I am still getting TimeOut errors. So the next question is can I increase the TimeOut value? I suspect this connection only needs to be made once during configuration. In use I expect the select list will perform better as the query gets more specific after entry in one field. 

Thanks,

Veröffentlicht Thu, 29 Aug 2019 19:48:07 GMT von Phil Robson Senior Director Support - Americas
Steve,
Try creating and SQL index on the fields require for the view. You must filter, and filter quite heavily to enure that only the data required is returned.
How many rows in the view?



Phil Robson
Senior Director Support Americas

Sie müssen angemeldet sein um Beiträge in den Foren zu erstellen.