Problem: The "Failed to retrieve store dialogs"
This message can appear when opening the Web Client.
Error messages:
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60531.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer
and
Retrieving web baskets settings failed.
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See
http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60531.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer
Cause:
These error messages are caused because the WCF service WebBasketsWCF.svc cannot be accessed.
Solution:
To determine the cause, open the following link in the browser:
http:////DocuWare/Services/WebBasketsWCF.svc
e.g. http://localhost/DWWebClient/DocuWare/Services/WebBasketsWCF.svc
Contact DocuWare Support with the message which is shown there.
In most cases, this relates to missing authentication settings (either anonymous or Windows) for the directory ..DWWebClient\DocuWare\Services in the IIS Manager.
Problem: "Error rendering document"
This message can appear when rendering a document in the Web Client.
Error message:
Could not connect to http://localhost:9009/DWImaging. Tcp error code 10061: no connection could be made because the target machine actively refused
Causes:
- The DocuWare Imaging Server is not installed, not started or not accessible.
- Port 9009 may be blocked by a firewall.
Problem:
An error occurred while receiving the HTTP response to http://localhost:9009/DWImaging. This could be due to the service endpoint binding not using the HTTP protocol.
This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down). See server logs for more details
Cause:
Another application is running on this port.
Solution:
To find out which process is currently using this port, enter the command "netstat –ano" into the command line. The corresponding process can be found in the Task Manager using the PID.
Problem: "The specified path or filename is too long"
This message can appear when opening a document.
Error message:
The fully qualified name must be less than 260 characters and the path less than 248 characters.
Cause:
In Windows, there is a limitation for complete file names. Path and file name must not be longer than 260 characters. In the Web Client, this is composed as follows: path of the Web instance temporary directory and file name of the document.
Solution:
To shorten this, the temporary directory can be defined in another shorter path. Alternatively, another index field can be stated as the document name in DocuWare.
Problem: "Parser Exception"
This message can appear when launching a search.
Cause:
This is a general message and indicates that it was not possible to interpret the search term correctly. This is often the case in searches for special characters, e.g. "(" or ")".
Solution:
Special characters must therefore be masked with an oblique e.g. \( or \)
Problem: "This is not a signed language version of DocuWare"
This message can appear after logging on to the Web Client.
Cause:
The language file used under "...\DocuWare\Web Modules\WebClient Central\DocuWare\Languages\Strings\" (5.1b ...\DocuWare\Web Client Server\Web Common\DocuWare\Languages\Strings\) has been modified or is corrupted.
Solution:
The language file must be replaced.
Problem: "Object reference not set to an instance of an object"
This message can appear in the Web Client
Solution:
Check the log in the error log directory of the Web Client temporary directory. In most cases, conclusions on configuration errors are given by the corresponding log entry. This occurs because the result list, which is stored in the search dialog, is not published or not assigned to the user.
Problem: There is just a red cross when opening a document
In terminal server or remote desktop sessions: There is just a red cross when opening a document.
Cause:
The color depth is insufficient for display. A color depth of min. 16 bit is required for displaying documents in Web Client.
Problem: "http://tempuri.org/dwimaging/openfilecreator cannot be processed at the receiver"
This message can appear when opening a document.
Error message:
due to a ContractFilter mismatch at the EndpointDispatcher.
Cause:
The DocuWare Imaging Server does not have the same version status as the Web Client Server.
Solution:
Check whether the Service Pack / Update for the Imaging Server has been installed. Reinstall it if necessary.
Problem: It is not possible to send a document as an email (Click Once)
Solution:
- In many cases, the Click Once cache on the system concerned can be emptied with the following command:
rundll32 %windir%\system32\dfshim.dll CleanOnlineAppCache - If a 401 error message appears, check the authentication settings in the IIS Manager. Ensure here that only the anonymous authentication is activated for the "Apps" directory.
- If a 407 error message occurs, a proxy server is in use. Exclude the web server from use of the proxy.