Views:

 Behavior:
When searching via fulltext the following error is shown:


"The underlying connection was closed: An unexpected error occured on a receive"

Cause:
For fulltext support DocuWare is using Apache Tomcat Server (DocuWare Full Text Server) with Apache Solr Plugin.
This Solr plugin uses port 9012 by default. If this port is already in use by another application fulltext server will still start but Solr cannot be loaded. Then when using a fulltext search you will receive the error.

Solution:
First you can check which process is using port 9012. This can be identified by Windows command line tool netstat.
When running the command box as Administrator you can use following command for example to write a text file where you can search which ports are in use and by which process.
netstat -abo > C:\netstat.txt

To change the Solr plugin port the following steps are necessary:

  1. Adapt the port in the server.xml in the conf folder of the fulltext server installation path
    (Default: C:\Program Files\DocuWare\Full-Text Server (x64)\conf)
    In row <Connector port="9012" protocol="HTTP/1.1" you can change the port
  2. Change port in DocuWare Administration for Fulltext Server Connection to the port number you have entered in the server.xml
  3. Restart Fulltext Server