Ansichten:

Verhalten:
Bei der Volltextsuche wird folgender Fehler angezeigt:

"DIE ZUGRUNDE LIEGENDE VERBINDUNG WURDE GESCHLOSSEN: UNBEKANNTER FEHLER BEIM EMPFANGEN"

Ursache:
Für die Volltextunterstützung verwendet DocuWare einen Apache Tomcat Server (DocuWare Full Text Server) mit dem Apache Solr Plugin. Dieses Solr Plugin verwendet standardmäßig den Port 9012. Wenn dieser Port aber bereits durch eine andere Anwendung belegt ist startet zwar der Full Text Server aber das Solr Plugin kann nicht geladen werden und bei der Volltextsuche kommt es zum Fehler.

Lösung:
Zuerst kann einmal ermittelt werden welcher Prozess den Port 9012 verwendet. Das kann per Windows Kommandozeilentool netstat ermittelt werden. Wenn eine Kommandozeile als Administrator gestartet wird kann z.B. per Kommando netstat -abno >C:\temp\ports.txt eine Datei in C:\temp\ geschrieben werden die alle im Moment verwendeten Ports auflistet. Um den Port des Solr Plugins anzupassen sind folgende Schritte notwendig:

  1. Anpassung des Ports in der Datei server.xml im conf Verzeichnis des Installationsverzeichnisses des Fulltext Server (Standardpfad C:\Program Files\DocuWare\Full-Text Server (x64)\conf ) Die Datei kann per Texteditor geöffnet und bearbeitet werden . In der Zeile <Connector port="9012" protocol="HTTP/1.1" kann der Port angepasst werden.
  2. Anpassung des Ports in der Docuware Administration für die Fulltext Server Verbindung.
  3. Neustart des Fulltext Server Dienstes