Comportamento:
MySQL non ha abbastanza memoria libera.
Causa:
Quando si aggiorna DocuWare, la memoria assegnata al database MySQL non viene aumentata automaticamente. Ciò significa che i sistemi DocuWare aggiornati, provenienti da versioni precedenti, potrebbero non essere in grado di utilizzare la memoria necessaria.
Soluzione:
Prima di aumentare la memoria, arrestare il database e tutti i servizi di DocuWare. Creare un backup del file "my.ini" situato nella directory di installazione del database (directory predefinita: C:\Program Files (x86)\DocuWare\Internal Database). Quindi, aprire il file e modificare i seguenti parametri:
Predefinito: Valore consigliato:
innodb_buffer_pool_size=512M innodb_buffer_pool_size=1536M
innodb_log_file_size=10Minnodb_log_file_size=200M
Prima di riavviare il database, è importante copiare i due file "ib_logfile0" e "ib_logfile1" (C:\Program Files (x86)\DocuWare\Internal Database\data) in un'altra directory (ad esempio nel desktop). È quindi possibile avviare il database e verificare se i due file sono stati scritti con le nuove dimensioni. Se ciò non dovesse funzionare, reimportare il file "my.ini" originale e copiare nuovamente i due file originali "ib_logfile0" e "ib_logfile1".
Dopo che il database si è avviato senza problemi, è possibile avviare i servizi di DocuWare.
Se si verificano problemi sconosciuti, contattare il Support di DocuWare fornendo i log e le schermate del problema.
Si prega di notare: Questo articolo è una traduzione dall’inglese. Le informazioni contenute in questo articolo si basano sulla/e versione/i originale/i del prodotto in inglese. Potrebbero esserci piccoli errori, come nella grammatica usata nella versione tradotta dei nostri articoli. Sebbene non possiamo garantire la completa esattezza della traduzione, nella maggior parte dei casi troverà che è sufficientemente informativa. In caso di dubbi, torni alla versione inglese di questo articolo.
