Verhalten:
MySQL verfügt nicht über genügend freien Arbeitsspeicher.
Ursache:
Beim Upgraden von DocuWare wird der Arbeitsspeicher der MySQL Datenbank nicht automatisch erhöht. Somit kann es vorkommen, dass upgedatete DocuWare Systeme, die von älteren Versionen kommen, nicht genügend Arbeitsspeicher nutzen dürfen.
Lösung:
Bevor Sie den Arbeitsspeicher erhöhen, müssen Sie die Datenbank und alle DocuWare Dienste beenden. Erstellen Sie ein Backup der „my.ini“ Datei, welche sich im Installationsverzeichnis der Datenbank (Standard Verzeichnis: C:\Program Files (x86)\DocuWare\Internal Database) befindet. Öffnen Sie anschließend die Datei und ändern Sie die folgenden Parameter ab:
Standard: Empfohlener Wert:
innodb_buffer_pool_size=512M innodb_buffer_pool_size=1536M
innodb_log_file_size=10M innodb_log_file_size=200M
Bevor Sie die Datenbank erneut starten, ist es wichtig, dass Sie die beiden Dateien „ib_logfile0“ und „ib_logfile1“ im Verzeichnis „C:\Program Files (x86)\DocuWare\Internal Database\data“ in ein anderes Verzeichnis (z.B. Desktop) verschieben.
Anschließend können Sie die Datenbank starten und prüfen, ob die beiden Dateien mit der neuen Dateigröße geschrieben worden sind. Sollte dies nicht funktionieren, spielen Sie bitte die original „my.ini“ Datei wieder ein und kopieren Sie die beiden Original-Dateien „ib_logfile0“ und „ib_logfile1“ ins Ursprungsverzeichnis zurück.
Nach dem erfolgreichen Neustart der Datenbank, können nun die DocuWare Dienste wieder ausgeführt werden.
Falls Sie auf unerwartete Probleme stoßen sollten, melden Sie sich bitte mit den entsprechenden Logs und Screenshots des Problems beim DocuWare Support.