Publicado Tue, 01 Oct 2019 19:00:11 GMT por Nathan French Systems Analyst
DocuWare 7.1 - Build: 7.1.0.15287
Windows Server 2012 R2
MS SQL Server 2014
 
BACKGROUND
I noticed this error whenever I would enter the form configuration (picture attached).  It wasn't always like that, and I'm not sure exactly when it began or what brought it on - it could be related to applying a previous minor update which may have been applied prior to this message.

This form has about 65 fields which are indexed and filled in on a merge form.  The merge form itself has all of those plus another 25 fields (hidden on the web form) which are later populated by calculations in workflow. I have not wanted to recreate all of that.

Everything has been fully functional and working properly.  Still though, I am uneasy putting this into production as is. I made some copies of the workflow (all with the same message) and deleted here and there until it didn't error upon opening.

The culprit is the merge form entry itself.  Not any specific areas of it - using a different file, deleting all fill areas, deleting all indexing still gives the same message.  It was something about the mere existence of that merge form entry.

SOLUTION
  1. Test everything below with a COPY of the affected form, just to be sure. (My copies were also affected.)
  2. Under "Submission," switch from Merge Form to Web Form.
  3. Under Output choose a store dialog (I chose the same one the merge form had used - unsure if important)
  4. Under Indexing, index something
  5. Save the configuration
  6. Unsure if important, but it worked consistently:
    1. Go "back" to main Forms configuration
    2. Exit Configurations entirely or reload the page,
    3. Re-enter Forms and re-enter the affected form - NO ERROR
  7. Under "Submission" switch from Web Form back to Merge Form
  8. Enter merge form configuration - rejoice there is still your old merge form configuration.
  9. Within merge form config, verify Designer (fill areas), Output (store dialog), and Indexing are all still okay.
  10. Save. Exit merge form, exit whole form, refresh page to main Configurations.
  11. Navigate back to the previously affected form configuration and be satisfied to find no error.

Anyway, I hope this will help someone else who's searching for this message and can't figure out where it's coming from. 

Cheers,
- Nate
 
Publicado Tue, 01 Oct 2019 19:01:11 GMT por Matthias Wieland DocuWare Europe GmbH Sr. Director Support EMEA
Dear Nathan French! It looks like the Community cannot answer your question. Thats why we have opened a Support Request with the Number SR-111257-S1T7V for you. A Software Support Specialist will contact you directly to follow up. We will update this thread with the solution as soon as we have solved the Support Request. With Best Regards, DocuWare Support Team

You must be signed in to post in this forum.