Publicado Tue, 20 Apr 2021 12:30:05 GMT por Genesis Garma Team Leader - System & Solution Support
Hi,

Is there anyone here who can share documentation or procedure on how to setup/integrate docusign in Docuware Cloud & Docuware Workflow Designer? I've been searching for topics, documentation or KB article but I found nothing.

Thanks
Publicado Tue, 20 Apr 2021 15:48:56 GMT por Jon Weston File IT Solutions Sr Application Developer, RIM specialist
Here you go: https://support.docuware.com/en-us/knowledgebase/article/KBA-36398
Publicado Tue, 20 Apr 2021 16:03:12 GMT por Genesis Garma Team Leader - System & Solution Support
Hi Jon Weston,

Thank you for your quick reply.
Do you have step procedure that you can share on how to configure Docusign in Web Services Configuration?

 
Publicado Tue, 20 Apr 2021 16:07:24 GMT por Genesis Garma Team Leader - System & Solution Support
Hi Jon,

Please see error message when trying to configure docusign in Docuware Web Services.

Thanks
Publicado Tue, 20 Apr 2021 16:18:58 GMT por Genesis Garma Team Leader - System & Solution Support
What URL do I need to input in Web Services configuration in Docuware?
I already have the token sent to me.
Publicado Tue, 20 Apr 2021 16:24:04 GMT por Jon Weston File IT Solutions Sr Application Developer, RIM specialist
I've not actually done this before - I only have the KB in front of me because I'll be doing it this week - but from looking at your screencap and looking at the kb it appears that the URL you're using is wrong, it should be https://signature.docuware.cloud/DocuSignSignatureService.svc
 
Publicado Tue, 20 Apr 2021 17:38:39 GMT por Genesis Garma Team Leader - System & Solution Support
Hi,

I've actually done in configuring the web services as well as the workflow as instructed in the KB.
And now I'm trying to store documents in my file cabinet but it seems the docusign is not working.
Should I received an email notification that I have documents needs to be sign using docusign?

Thanks
Publicado Tue, 20 Apr 2021 17:43:20 GMT por Genesis Garma Team Leader - System & Solution Support
Hi,

this screenshot is not complete in KB.

Thanks
Publicado Tue, 20 Apr 2021 17:49:09 GMT por Genesis Garma Team Leader - System & Solution Support
Hi Jon Weston,

I provided to screenshots of the workflow here.
One is from the KB you provided and one is from my own workflow.
I just want to know if this is already the same? I've noticed that the Icon for Docusign Remote in KB is different in mine.
Also, thus this work on Docuware Cloud Environment?

Thanks
Publicado Tue, 20 Apr 2021 18:09:46 GMT por Jon Weston File IT Solutions Sr Application Developer, RIM specialist
The icons in the workflow are probably different because the kb might have screenshots from version 7.4.  Either way, you're using the web service block in the workflow so it's correct.

Yes, this will work in DocuWare Cloud as well as on-premise.

Yes, if everything is working then you should be getting an email from DocuSign saying that you have a document to be signed.  If that's not happening then I'd probably start off by checking your workflow to make sure it's being triggered and then i'd go on to checking the DocuSign account and settings to see if it's all setup correctly.
Publicado Tue, 20 Apr 2021 23:42:34 GMT por Genesis Garma Team Leader - System & Solution Support
Hi Jon Weston,

Good Day to you.
I attached here in my reply my whole configuration of my Docuware Web Services.

Hope you can help me with this thing.

Thank You.
Publicado Wed, 21 Apr 2021 00:10:17 GMT por Genesis Garma Team Leader - System & Solution Support
Hi,

You mentioned that I also need to check the settings from my Docusign Account itself.
I provided again the screenshot and want to ask if this particular settings you are pertaining to?

Thank You.
Publicado Wed, 21 Apr 2021 06:34:28 GMT por Fabian Kall
Hi,

I'd like to help by answering some of your questions in the word document you sent, starting on oage 4:

Webservice credentials:
You have entered the correct credentials here, otherwise you would not be able to set any values or use the "Find methods" button for this webservice in the workflow designer.
You also have the "Test connection" button in the webservice configuration. If you click this and you get a green response popup (save settings first), the url and the credentials are fine.

WebService parameters:
While some values may be optional, I believe You are missing some parameters that are necessary for the signature process to work. 
For instance: You are trying to create a signature process of type "remote" (Method AddNewDocumentRemote"), which I sets up communication with the signer via email. You are providing the parameters EmailMessage and EmailSubject, but not SignerEmail.
Read the documentation for the webservice DocuWare has provided. There should be an explanation for each parameter.

Also, if you are actually using the webservice with a document and you are missing a parameter or sending an invalid parameter, the webservice will give you feedback on the problem. That is what the result parameters of the webservice are for.

Set up global variables for Message, Success and EnvelopeID, then set these global variables under "result parameters".
You do not need to supply values for these global variables, the webservice will do that for you. So you can run the workflow with test documents and check the workflow history for the result parameters to gain insight if something went wrong during development of the workflow.
 
Publicado Wed, 21 Apr 2021 07:27:36 GMT por Genesis Garma Team Leader - System & Solution Support
Hi Fabian Kall,

Good day.
Thank you for giving your thoughts.
Let me ask another question, Is there also any settings that I need to do in my docusign account?

You must be signed in to post in this forum.