Vues :

Problème :
Lorsque vous effectuez une recherche en texte intégral, vous obtenez le message d'erreur suivant :

Un élément avec la même clé a déjà été ajouté.

Cause :
Lors de la mise à jour vers DocuWare 6, des doublons ont peut-être été créés dans le catalogue en texte intégral pour certaines DOCID.

Solution :
N'effectuez la modification décrite ci-dessous que si aucun utilisateur n'est connecté à DocuWare. Veuillez également créer une copie de sauvegarde du répertoire de l'index en texte intégral.

Ouvrez l'URL suivante :http://servername:9012/solrt/FCGuid/update?stream.body=%3Cdelete%3E%3Cquery%3E*%3A*+-DOCID_s%3A%5B%22%22+TO+*%5D%3C/query%3E%3C/delete%3E&commit=true dans un navigateur.

Veuillez adapter le nom du serveur et l'armoire de fichiers (FCGuid). Après quelques secondes, un nouveau site web est chargé avec un fichier XML. Le problème devrait alors être résolu. Il sera peut-être nécessaire de redémarrer le serveur de texte intégral


Veuillez noter : Cet article est une traduction de l'anglais. Les informations contenues dans cet article sont basées sur la ou les versions originales des produits en langue anglaise. Il peut y avoir des erreurs mineures, notamment dans la grammaire utilisée dans la version traduite de nos articles. Bien que nous ne puissions pas garantir l'exactitude complète de la traduction, dans la plupart des cas, vous la trouverez suffisamment informative. En cas de doute, veuillez revenir à la version anglaise de cet article.