Vistas:

Problem:
When doing a full text search you get the following error message:

An element with the same key has already been added.

Cause:
When updating to DocuWare 6 maybe duplicated entries were created in the full-text catalog for some DOCID’s.

Solution:
Perform the change described below only if no user is logged in DocuWare. Please create also a backup copy of the full text index directory.

Open the following URL: http://servername:9012/solrt/FCGuid/update?stream.body=%3Cdelete%3E%3Cquery%3E*%3A*+-DOCID_s%3A%5B%22%22+TO+*%5D%3C/query%3E%3C/delete%3E&commit=true in a browser.

Please, adapt the server name and the file cabinet (FCGuid). After a few seconds a new website is loaded with an XML file. The problem should then be solved. Maybe it will  be necessary to restart the full text server.