Problema:
Quando si esegue una ricerca full text viene visualizzato il seguente messaggio di errore:
Un elemento con la stessa chiave è già stato aggiunto.
Causa:
Durante l'aggiornamento a DocuWare 6 potrebbero essere state create voci duplicate nel catalogo full-text per alcuni DOCID.
Soluzione:
Eseguire la modifica descritta di seguito solo se nessun utente è connesso a DocuWare. Creare anche una copia di backup della directory dell'indice full-text.
Aprire il seguente URL: http://servername:9012/solrt/FCGuid/update?stream.body=%3Cdelete%3E%3Cquery%3E*%3A*+-DOCID_s%3A%5B%22%22+TO+*%5D%3C/query%3E%3C/delete%3E&commit=true in un browser.
Adattare il nome del server e il file cabinet (FCGuid). Dopo pochi secondi viene caricato un nuovo sito web con un file XML. Il problema dovrebbe essere risolto. Forse sarà necessario riavviare il server full text.
Si prega di notare: Questo articolo è una traduzione dall’inglese. Le informazioni contenute in questo articolo si basano sulla/e versione/i originale/i del prodotto in inglese. Potrebbero esserci piccoli errori, come nella grammatica usata nella versione tradotta dei nostri articoli. Sebbene non possiamo garantire la completa esattezza della traduzione, nella maggior parte dei casi troverà che è sufficientemente informativa. In caso di dubbi, torni alla versione inglese di questo articolo.
