Vistas:

Behavior:
For DocuWare systems with MySQL (especially with large file cabinets), it can happen that one of the tables is inconsistent or corrupted. This reveals itself in various ways in DocuWare. In addition to the obvious message: "Error storing document: [filecabinet_tablename] is marked as crashed and should be repaired", this message always appears: "Error storing document: duplicate entry 'REINDEX' for key 2".

Possible Causes

  • Unstable operating systems
  • Hardware problems
  • Power outages
  • MySQL Server process crashes during runtime
  • External programs trying to change data in the database at the same time as accessing the data

Solution:
Check Tables
To fix the problem, MySQL Administrator must be installed (part of MySQL GUI tools – see "Further Links" section). After successfully logging in to the database, an overview of all database tables can be opened under "Catalogs". This is where tables are marked red if they have already been identified by the program as "corrupt".

Here you can now have one or more tables checked by the program by selecting the table(s) you want and then selecting "Maintenance" and "Check Table" from the context menu.

For the Check method, it is recommend that you choose the "Extended" setting, even if this takes longer to process.

Once the check is finished, results are displayed to show which tables are corrupt and whether they should be repaired.

Repair Tables
The process for repairing tables is similar. Select the table(s) to repair and go to "Maintenance" -> "Repair Table" in the context menu.

Again, the recommended Repair method is "Extended". The additional options available are not required.

After the repair is complete, use the results dialog to see whether the table repair was successful.
Documents can then be stored in DocuWare again.

Further Links
MySQL GUI Tools