Comportamento:
DocuWare Desktop non elabora alcun documento e la connessione mostra una X rossa.
Inoltre non è possibile aprire la pagina di Configurazione Web.
Quando si richiamano gli URL
- http://<SERVERNAME>/DocuWare/Settings/SettingsService.svc
- http://<SERVERNAME>/DocuWare/JobServer/Repository/help
viene visualizzato il seguente messaggio di errore:
"Ilcontrollo dei gate di memoria non è riuscito perché la memoria libera (... byte) è inferiore al 5% della memoria totale. Di conseguenza, il servizio non sarà disponibile per le richieste in arrivo.Per risolvere il problema, ridurre il carico sulla macchina o regolare il valore di minFreeMemoryPercentageToActivateService sull'elemento di configurazione serviceHostingEnvironment."
Causa:
Questo problema si verifica spesso sui server Windows Small Business, perché MS SQL Server e MS Exchange consumano già gran parte della memoria disponibile.
Questo può far sì che la memoria disponibile per l'avvio del Servizio impostazioni di DocuWare (Servizio WCF) non sia sufficiente.
Il Servizio impostazioni e il Job Server sono servizi centrali utilizzati da molti componenti di DocuWare. Senza questi servizi, DocuWare non può essere utilizzato.
Soluzione:
Una soluzione potrebbe essere quella di limitare la memoria disponibile per MSSQL,vedere http://msdn.microsoft.com/en-us/library/ms178067.aspx
In ogni caso, si consiglia di aumentare la memoria disponibile!
Come soluzione temporanea, è possibile ridurre la memoria disponibile minima richiesta a un limite inferiore (ad esempio, l'1% della memoria totale). A tal fine, aggiungere il seguente parametro ai file:
- "C:\Program Files (x86)\DocuWare\Web\Settings\Web.config".
- "C:\Program Files (x86)\DocuWare\Web\JobServer\Web.config".
...
<system.serviceModel>
<serviceHostingEnvironment multipleSiteBindingsEnabled="true" aspNetCompatibilityEnabled="true" minFreeMemoryPercentageToActivateService="1" />
<bindings>
...
Dopo aver salvato le modifiche, il Servizio impostazioni e il Job Server dovrebbero essere nuovamente disponibili.
Non è necessario riavviare alcun componente di DocuWare.
Si prega di notare: Questo articolo è una traduzione dalla lingua inglese. Le informazioni contenute in questo articolo si basano sulla/le versione/i originale/i del/i prodotto/i in inglese. Potrebbero esserci errori minori, come nella grammatica utilizzata nella versione tradotta dei nostri articoli. Sebbene non possiamo garantire la completa accuratezza della traduzione, nella maggior parte dei casi troverai che è sufficientemente informativa. In caso di dubbio, fai riferimento alla versione inglese di questo articolo.
