ビュー:

動作
DocuWare Desktopでドキュメント処理が行われず、接続に赤い×印が表示されます。
さらに、Web設定ページを開くことができません。

URLを呼び出すと、次のようになります。


空きメモリ(...バイト)が総メモリの5%未満であるため、メモリゲートのチェックに失敗しました。その結果、サービスは着信リクエストに対応できません。これを解決するには、マシンの負荷を減らすか、serviceHostingEnvironmentのconfig要素のminFreeMemoryPercentageToActivateServiceの値を調整してください。"

原因:
Windows Small Businessサーバーでは、MS SQL ServerとMS Exchangeがすでに利用可能なメモリーの大部分を消費しているため、この現象がよく発生します。
これにより、DocuWare設定サービス(WCFサービス)を起動するのに十分なメモリーが利用できなくなる可能性があります。

設定サービスとJob Serverは、多くのDocuWareコンポーネントで使用される中心的なサービスです。このサービスがないと、DocuWareを使用することができません。

解決方法:
MSSQLで使用可能なメモリを制限することも解決方法の1つですhttp://msdn.microsoft.com/en-us/library/ms178067.aspx
いずれにしても、使用可能なメモリを増やすことをお勧めします!

一時的な解決方法として、使用可能なメモリの最小必須値を下限値(総メモリの1%など)に下げることができます。 これを行うには、次のパラメータをファイルに追加します:

  • "C:◆Program Files (x86)◆DocuWareWeb◆設定◆Web.config"
  • "C:◆Program Files (x86)◆DocuWare◆Web◆JobServer◆Web.config"

...
<system.serviceModel>
<serviceHostingEnvironment multipleSiteBindingsEnabled="true" aspNetCompatibilityEnabled="true"minFreeMemoryPercentageToActivateService="1"/>
<bindings>
.
..

変更を保存した後、設定サービスとJob Serverは再び使用できるようになります。
DocuWareコンポーネントの再起動は必須ではありません。

 

ご注意:この記事は英語からの翻訳です。この記事に含まれる情報は、オリジナルの英語版製品に基づくものです。翻訳版の記事で使用されている文法などには、細かい誤りがある場合があります。翻訳の正確さを完全に保証することは出来かねますが、ほとんどの場合、十分な情報が得られると思われます。万が一、疑問が生じた場合は、英語版の記事に切り替えてご覧ください。