Ansichten:

Behavior:
When installing the DocuWare Platform API, you get the following error, 

Could not install package 'DocuWare.RestClient 10.4.300696'. You are trying to install this package into a project 
that targets '.NETFramework,Version=v4.5', but the package does not contain any assembly references or content files that are compatible with that framework.


Solution:
This error occurs when installing version 7.3 of the DocuWare Platform API, which does not support .NET Framework 4.5 as the Target framework. 
You will need to have at least .NET Framework 4.6 or above as the chosen Target framework. Additionally, you may also refer to our Developer Pages to see which versions of API would be compatible to your system depending on your DocuWare version.

To make this change from Visual Studio, do the following, 

  1. Go to Project -->  "Project Name" Properties
  2. When the new window appears, from the dropdown "Target framework", choose a version which is 4.6 or greater. 
    If no version greater than 4.5 exists, please visit the following link to download the .NET framework developer pack.
    Install the .NET Framework developer pack or redistributable | Microsoft Docs

Once this change has been made, you should be able install the API.

KBA applicable for both Cloud and On-premise Organizations.