Posted Fri, 02 Nov 2018 23:10:47 GMT by Leon Gibbons IT Technician

I created an Index Value Profile today with a Query Definition using Graphical Editor like this:

Authoriser  |  Is (where clause)  |  *CURRENTUSEREMAIL()

This is so the user can only read documents that contain their email address. The Authoriser field stores a code number and their email address like this "EGD1234" so I used the wildcard * together with CURRENTUSEREMAIL() to get the result.

When I first tested this it worked as expected. The logged in user could only see documents that had their email address in the Authoriser field. The user only had this one file cabinet profile and nothing else.

Now a couple of hours later and it no longer works. When the user does a search they get the error message: Wrong condition. Not parsed string ')' for field 'Authoriser'

Nothing has changed, I don't understand why this worked initially and now doesn't?

Posted Mon, 05 Nov 2018 12:33:50 GMT by Phil Robson DocuWare Corporation Senior Director Professional Services, Americas

I am not at all sure why it worked initially, but the error indicates that it is not expecting the parenthesis is the string.
An easier way is to use the Contains operator, and select Email of the user as the entry. The result will be what you want, but DocuWare will contruct the query correctly.


Phil Robson
Senior Director Support Americas

Posted Tue, 06 Nov 2018 10:35:08 GMT by Leon Gibbons IT Technician

Hi Phil,

I did try the contains and then email of the user, but that did not appear to work.

However now that I think about it, since the update to v7 I've noticed a delay in changes that I make actually starting to appear. I'll retry it and allow it some time to settle in :)

Posted Thu, 08 Nov 2018 15:28:34 GMT by Simon H. Hellmann Wedderhoff IT GmbH Systemadministrator

Hello Leon, hello Phil,

I started to notice similar weird behaviour in DW7, both Cloud (EMEA) and On-Premise. The issue affects Workflow Designer, Archive Configuration and Autoindex - maybe more modules.

It seems as if DocuWare now requires each special Char (like ')' ) to be escaped by a backslash (\) - otherwise Errors start to appear. For example, I recently had a search dialog configured to search for : Rechnung (eingehend)

Up to 6.12 this worked, since 7 I now either need to escape the paranthesis or put everything into these: " ".

I also had a workflow configured to start on every Document with Document Type "Rechnung (eingehend)" - this one was never triggered until I changed the condition to "Rechnung \(eingehend\)".

This simple change in string parsing behaviour seems to probably affect some more stuff than dev originally thougt.

Phil, ould you please check if there is already a bug # assigned to this problem and if a hotfix is underway or if this is by design now.

Greetings from Germany,
Simon H. Hellmann
DocuWare System Consultant

You must be signed in to post in this forum.