Views:

Introduction:
The Connect to Outlook module provides a connection with Microsoft Outlook, which enables emails to be archived and Web Client to be integrated. This makes it possible to index and convert documents automatically, archive them by drag & drop, and monitor folders, etc. It is also possible to have an integrated search and display of associated documents from DocuWare file cabinets in Outlook, e.g. documents from the same sender from a certain date. The number of archiving and search configurations is unlimited and connections to different DocuWare systems can be established.

Requirements:
Please always check the system requirements, especially which Outlook versions are supported:

Troubleshooting:

  • Ensure that the Outlook version in use is 32-Bit. 64-Bit is not supported by now
  • Ensure that Cache Mode is enabled. The module is not able to run properly without this mode.
  • Installation directory (if necessary with x86): C:\Program Files\DocuWare\CONNECT to Outlook.
  • Configuration file "CONNECTtoOutlookApplicationConfiguration.xml": %appdata%\DocuWare\CONNECT to Outlook.
  • ADX Registrator / Loader: %userprofile%\Documents\Add-in Express.
  • Monitored folders are not supported in Terminal Service environments and machines being remote controlled with Windows Remote Desktop. RDP utilizes the component of Terminal Service, that causes monitored folders to not import documents.

 

Error after installing Connect to Outlook (6.6 or older):
Sometimes you may get an error, that there is something wrong with the XML configuration file or you get the following error messages:

  • Error DocuWare Connect to Outlook. The Add-In has fired an exception
  • Object reference not set to an instance of an object

Please try the following steps:

  1. Close Outlook
  2. Delete the file "CONNECTtoOutlookApplicationConfiguration.xml" in the folder "%appdata%\DocuWare\CONNECT to Outlook"
  3. Restart Outlook, so that the file is created from scratch
  4. Add the configuration information in the "Preferences" on the DocuWare tab within Outlook
  5. Close Outlook
  6. Copy the files (not the folder "x64") from the folder "D:\Program Files\DocuWare_Client\Client Modules\Gapi" to the installation directory of Connect to Outlook "C:\Program Files\DocuWare\CONNECT to Outlook"

Note: DocuWare Connect to Outlook uses GAPI, therefore, the DocuWare ports have to be open between the client and DocuWare server.

DocuWare elements are not displayed:
Enable add-in:

  • Office 2007: After starting Outlook as administrator, click "Tools" > "Security Center" > "Add-Ins" > select "COM Add-Ins" and click "Go to..." > enable "CONNECT to Outlook" add-in
  • Office 2010: After starting Outlook as administrator, click "File" > "Options" > "Add-Ins" > select "COM Add-Ins" and click "Go to..." > enable "CONNECT to Outlook" add-in
  • Additional in Outlook 2013: File > Add-Ins configuration > That Add-in always active.

If the add-in cannot be loaded:

  • check the ADX log files (see "ADX Registrator/Loader" path)
  • The next step is to install the add-in, or to register the add-in in a prompt with the extended rights.
  • Using a command prompt with elevated privileges, change the directory to: C:\Program Files (x86)\DocuWare\Connect to Outlook
  • Then execute this command:  adxregistrator.exe /install=DocuWare.CONNECTtoOutlook.dll /privileges=admin 

Add-In cannot be started:
Even though installation was successful, the add-in cannot be started. Trying to start the add-in manually results in a "Certificate error" message.

Solution 1: Start Outlook as administrator

  • Office 2007: After starting Outlook as Administrator, click "Tools" > "Security Center" > "Add-Ins" > select "COM Add-Ins" and click "Go to..." > enable "CONNECT to Outlook" add-in
  • Office 2010: After starting Outlook as Administrator, click "File" > "Options" > "Add-Ins" > select "COM Add-Ins" and click "Go to..." > enable "CONNECT to Outlook" add-in

Solution 2: Disable "Macro security settings ..."

  • Office 2007: "Tools" > "Security center" > "Add-Ins" > disable "Accept macro security settings for installed add-ins" > restart Outlook > try enabling the add-in again
  • Office 2010: "File" > "Options" > "Security Center" > "Security Center Settings" > "Macro Settings" > disable "Accept macro security settings for installed add-ins" > restart Outlook > try enabling the add-in again

Connection to DocuWare server fails:
Displayed message: No license found for Connect To Outlook at the used DocuWare Organisation.

Solution: Add a new External Connection to the DocuWare services at the DocuWare Administration. Use the server name and port which is entered at the Connect To Outlook configuration settings in Outlook. 

SMTP address resolution:
If the SMTP address for a certain contact is not correctly resolved, it will not appear in the target field of the file cabinet. Consequently the index extension will not be added for the "Company" and "Contact" fields, if this is configured.

Solution 1: Download exchange address book

  • Office 2007: "Tools" > "Send/Receive" > "Download Address Book"
  • Office 2010: "File" > "Information" area > "Account Settings" > "Download Address Book"

Solution 2: Compress local Outlook file

  • Office 2007: "Tools" > "Account Settings" > "Data Files" tab > double-click on account data file > "Advanced" tab > "Outlook Data File Settings" > Click "Compress now". This may take some time.
  • Office 2010: "File" > "Information" area > "Account Settings" > "Account Settings" > "Data Files" tab > Double-click on account data file > "Advanced" tab > "Outlook Data File Settings" > click "Compress now".
    This may take some time.

Monitored folder in inbox:
To set up a monitored folder in the "Inbox" the variable (INBOX) can be used. For example, the path "(INBOX)\DocuWare\Incoming Invoices" can be entered, so only the last directory in the tree is monitored.

Logging:
Logging till 6.7:

  1. To set up an advanced local log for the Connect to Outlook module, GAPI logging must be enabled in "DocuWare.Gapi.dll.config" in the add-in installation directory:
  2. Here you can copy the text: 
    <loggingManagement mode="on" trace="on"><publisher type="DocuWare.Common.Logging.FilePublisher" logname="TS log" logLevel="Debug" fileName="C:\Temp\C2OLog.txt" maxFileSize="10000" enhancementMethod="oneFile" maxFileNumber="10" deleteFirstNKBytes="50" deleteFirstNEntries="100" mode="on" assembly="DocuWare.Common"><publisherInfo date="on" time="on" textID="on" message="on" logLevel="on" codeLocation="on" addText="on" user="on" application="on" threadID="on" winID="on" computer="on" assembly="on" /></publisher><applicationInfo date="on" time="on" textID="on" message="on" logLevel="on" codeLocation="on" addText="on" user="on" application="on" threadID="on" winID="on" computer="on" assembly="on" /></loggingManagement>


Logging since 6.7:

  1. Search following line in the file DocuWare.CONNECTtoOutlook.dll.config at the installation drive from Connect To Outlook
  2. Change the value "Error" to "Debug": 
    <loggingManagement mode="on" trace="on"><publisher type="DocuWare.Common.Logging.FilePublisher" logname="TS log" logLevel="Debug" fileName="C:\Temp\C2OLog.txt" maxFileSize="10000" enhancementMethod="oneFile" maxFileNumber="10" deleteFirstNKBytes="50" deleteFirstNEntries="100" mode="on" assembly="DocuWare.Common"><publisherInfo date="on" time="on" textID="on" message="on" logLevel="on" codeLocation="on" addText="on" user="on" application="on" threadID="on" winID="on" computer="on" assembly="on" /></publisher><applicationInfo date="on" time="on" textID="on" message="on" logLevel="on" codeLocation="on" addText="on" user="on" application="on" threadID="on" winID="on" computer="on" assembly="on" /></loggingManagement>
  3. Restart Microsoft Outlook
  4. You will find a log-file at the folder %TEMP%\DocuWare\Logs\

Other FAQ information

  • A Connect to Outlook license is required and a concurrent license is needed to log in.
  • It is not possible to convert an Active Import license into a Connect to Outlook license.
  • Connections to several DocuWare systems are supported but not at the same time.
  • Windows login is also possible outside a network, if the client and server are in the same domain.
  • SQL connection and query tests will be run by Content Server – SQL access is from the client for the run time.
  • Generally in the event of problems it is recommended, that you run Outlook with administrative rights, disable the Cached Exchange Mode (for testing purpose), or compress the local data file.

Further Links