Publicado Thu, 02 Aug 2018 08:22:25 GMT por Benoit Vassart

Dear,

Has anyone had issue with the upgrade of workflow from 6.9-6.12 for assigning external data and variables? 

 

Our issue is using 'quotes' within the SQL queries. 

Version 6.9, we had the following:

Assign data (arithmetics): GVmyVariable = "'" + GVmyVariable + "'"  --> Result should be GVmyVariable with quotes

Assign from external source: 

the select clause was like:  Select MyColumnName from DatabaseName where myField = GVmyVariable (without quotes, because they are set in the previous step)

Version 6.12: This was not working anymore. (in fact, the workflow engine seems to add on his own quotes)

 Workaround: Removing the first arithmetic operation GVmyVariable = "'" + GVmyVariable + "'" and set the quotes within the SQL query: 

Select MyColumnName from DatabaseName where myField = 'GVmyVariable

Very annoying issue, specially for active documents within the workflow.

 

Kind Regards

 

 

 

Publicado Thu, 02 Aug 2018 09:27:43 GMT por Phil Robson

Benoit,
I am sure it is annoying to have to correct the queries, however the way you were doing it before was really creating a literal string including the quotes. As the workflow engine has evolved quite substantially these types of problems will show themselves. Quotes are always added around strings when constructing the query.

Phil Robson
Senior Director Support Americas

Publicado Thu, 02 Aug 2018 10:02:52 GMT por Benoit Vassart

Dear Phil,

You're right, but in our case, the design was done by a Docuware consultant. :(   (maybe an issue with the previous engine can explain the way of working ?)

Our main issue is with the active documents when upgrading. It's almost impossible for us to know if our workflow will still working after an upgraded workflow engine. If not, the documents will go into an error state and the workflow will stop. 

This will also be the case for further versions. 

I've found a similar issue when upgrading and some components were not supported anymore:

https://www.docuware.com/forum/english-forums/docuware-help-technical-pr...

(Thanks for the webinar yesterday, very interesting, specially for upgrades)

Benoît, 

Publicado Thu, 02 Aug 2018 13:44:07 GMT por Phil Robson

Hi Benoit,
It certainly is an odd way of solving a problem. I have not seen any of our Pro Services engineers use that method here in the US. But undoubtedly they were using a work-around. Before you consider going to DocuWare 7, please check the technical documentation on the changes in workflows so that you do not get any more surprises!

 

Phil.

You must be signed in to post in this forum.