Publié Mon, 14 Oct 2019 18:51:41 GMT par Phillip Enns Systems Admin
Have created an email notification to go out that sends a Date/Time Index Field as part of the description for the email.   The time appears to be received as the incorrect time on these emails and are 7 hours off in time.  Possible a Time Zone issue?  Please advise on how to correct.   Verified Index field shows correct date/time but email is showing incorrect time.  
Publié Mon, 14 Oct 2019 19:04:37 GMT par Phil Robson DocuWare Corporation Senior Director Client Services, Americas
It is important to set the Server Time Zone in DocuWare Administration. The default is UTC therefore your dates are being delivered as UTC.
Run the DocuWare Desktop App > DocuWare Administration as the DocuWare Administrator (or user with Organizational Admin rights).
Navigate to your Organization (at the top of the tree) > General.
Under the section Calendar, set the appropriate Time Zone for your physical location. Click Apply, then OK.
Any new notification sent should now have the Date/Time offset correctly.

Phil Robson
Senior Director Client Services, Americas
Publié Mon, 14 Oct 2019 19:05:11 GMT par Joe Kaufman Manager
Phillip,

DocuWare stores all timestamp indexes in UTC time (like GMT). It would appear that when fields are sent out as part of a notification they come out as their literal stored date/time without being translated into any other time zone. This makes sense, as what if the email is sent to someone halfway across the world? Would you want to show the time as it was stored from a specific client location, or just treat everything as UTC so various destinations can shift accordingly?

The reason the indexes in the web client view show as local time is because all timestamps are converted back to the timezone of the one currently viewing the information.

I am curious to see what DocuWare support has to say, though, as I could see you wanting the time to be translated into some other time zone...

Thanks,
Joe Kaufman
Publié Mon, 14 Oct 2019 22:08:43 GMT par Phillip Enns Systems Admin
Thanks for the responses.  I believe Phil Robson's response should do it.  For some reason overlooked that setting and was set incorrectly. 

You must be signed in to post in this forum.