Vues :

Comportement :

L'API de la plate-forme ne trouve pas de bacs à documents ou d'armoires à dossiers de manière fiable.


Cause :

Ce comportement peut s'expliquer par l'existence de plusieurs bacs ou armoires à documents portant un nom similaire, voire identique. (Chaque utilisateur a un Bacs nommé "Inbox" et l'utilisateur admin les voit tous, par exemple.)
Si vous voulez obtenir l'objet dans votre Platform-tool en utilisant le nom, il peut arriver que vous obteniez le mauvais ou pas du tout. Cela dépend de la méthode utilisée dans le code.


Solution :

Dans vos outils de plate-forme, vous devez toujours utiliser l'ID pour obtenir l'objet correct. Cet identifiant est unique dans tout le système et il est donc impossible de se tromper.

 

Veuillez noter : Cet article est une traduction de l'anglais. Les informations contenues dans cet article sont basées sur la ou les versions originales des produits en langue anglaise. Il peut y avoir des erreurs mineures, notamment dans la grammaire utilisée dans la version traduite de nos articles. Bien que nous ne puissions pas garantir l'exactitude complète de la traduction, dans la plupart des cas, vous la trouverez suffisamment informative. En cas de doute, veuillez revenir à la version anglaise de cet article.