Ansichten:

Verhalten:

Die Platform API findet den angegebenen Briefkorb bzw. das angegeben Archiv nicht zuverlässig.


Ursache:

Eine mögliche Ursache für das Verhalten ist, dass es mehrere Briefkörbe/Archive mit einem ähnlichen, oder gar demselben Namen im System gibt. (Bspw. wenn jeder User einen Briefkorb "Inbox" besitzt, auf die der Admin-Uder Zugriff hat.)
Wenn Sie in Ihrem Platform-Tool nun das jeweilige Objekt anhand des Names ermitteln, kann es dazu führen, dass die Platform API dieses Objekt nicht finden kann, oder das falsche zurückliefert. Dies hängt natürlich auch von der Methode ab, die Sie im Quellcode nutzen.


Lösung:

Es bietet sich an, bei Tools, die die Platform API nutzen, immer mit der ID des Objekts zu arbeiten. Diese ist im gesamten System eindeutig, wodurch Verwechslungen ausgeschlossen werden können.