Views:

Behavior:
Starting with DocuWare Version 6.6 an upgrade simulation is available withtin the setup, which checks if the are any errors regarding the upgrade of the DWSystem before running the upgrade.
If there is a failure you'll get an error message stating that the system cannot be upgraded:
The DocuWare system analyzer has detected errors during the upgrade simulation.
Setup cannot continue in order to prevent damage from your DocuWare Installation.
Please contact the DocuWare Support for assistance in completing your upgrade.

Solution:
To find out the cause proceed as follows:

  1.  Open the DocuWare Setup Logs folder
  2. You'll find the DWSetup.log in %ALLUSERSPROFILE%\DocuWare\SetupLogs
  3. Open the DWSetup.log in an editor and search for the word exception from bottom to top
  4. Check the following known issues or contact the DocuWare Support with the logfile.

Known Issues:

  1. Backup could not be created C:\Users\<USERNAME>\AppData\Local\Temp\<filename>.bak'. (Aceess denied)
    Cause:
    For the simulation a backup of the DWSystem database is created in the temp. folder (%temp%) of the windows user which has started the DocuWare Setup (C:\Users\<USERNAME>\AppData\Local\Temp\).
    However the backup is created by the user which is running the database service (e.g. local system).
    This user has no read/write permissions on the  target folder.
    Solution:
    Grant read/write permissions to the user which is running the database service on the temp. folder of the windows user which has started the DocuWare Setup.