Publié Tue, 20 Mar 2018 15:18:16 GMT par Joe Kaufman Bell Laboratories Inc No longer there

Hey all,

I got basic notifications working (ones configured in the web client). So, I thought I would set up the simplest full Workflow possible to mimic that -- send out an email when an index changes or a document is added to a file cabinet.

All it is is a Start --> Email --> End flow. The Start is triggered by the same thing I have set up in my web-based Notification on the same file cabinet.

The email is being sent out to a manually-entered email address and to a DocuWare user (myself). Permissions are to myself. The Workflow is published. Notify and Workflow services have been restarted several times. Thw Workflow tests fine and says it completed.

When I go change the index, I get a notification via the web-based configuration, but I have yet to receive a notification from the workflow. I cannot tell if it is not triggering, if the emailing is failing, or anything. I do not know of a Workflow log to see what is happening (or not happening). I appear to have done everything I need to do as listed in the documentation.

I am very new to Workflow, but surely this simplest of all Workflows should work? Is there some other global organization switch or file cabinet switch I need to check to make sure Workflows are allowed to run? The file cabinet does have the admin option "Email Notifications and Workflow Manager allowed" checked.

Sorry for such a newbie question, but I'm stuck...

UPDATE: I don't even know if any Workflows are running. I do not even see a "Tasks" header at the top of my DocuWare web client when a task should be getting created directly for me. In reading the help file, there is this part:



  • Workflow Engine Server
    The Workflow Engine Server is installed within DocuWare Setup as a server component.
  • Workflow Designer
    Install Workflow Designer on your client PC via the start menu of DocuWare Client.
  • Workflow tasks display in DocuWare Client
    In order to see the list of workflow tasks in DocuWare Client, you need to enable this function: DocuWare Client > Start menu > File cabinets and document trays > Enable the Workflows option.


I don't know what "Workflow Engine Server" is, nor how it differs from "Workflow Server". It is greyed out in the DocuWare Service Control Panel on the server.

I have Workflow Designer installed and have created two Workflows that test fine.

I do not know what the third bullet point means. What is the "DocuWare Client"? The web client? There is no "Start" menu there and I do not see anything on any menu that has a "Workflows" option.

Please advise -- I cannot even get Workflows off the ground, and the help file doesn't appear to help much as it focuses more on designing a Workflow than on troubleshooting why they aren't working at all in the first place.



Joe Kaufman

Publié Tue, 20 Mar 2018 18:35:33 GMT par Jon Weston File IT Solutions Sr Application Developer and RIM specialist

Hi Joe,

I had endless trouble just before Christmas with workflows simply not triggering.  We eventually figured out the the previous version of the workflow wasn't unpublishing properly when I clicked the unpublish button.  The resolution was to not unpublish the previous version, just edit it and publish the new version.  Not sure if this will help you, but give it a try.

Publié Tue, 20 Mar 2018 19:35:05 GMT par Casey Miller Director of Technical Services

Joe, your issue is that workflow engine service is not installed. Workflow server service does not run the workflow designer. Frankly, I am not sure how workflow designer is even allowing any publishing if you don't have workflow engine installed. I do know, if you don't have workflow engine service installed and licensed, nothing will work within the designer. I would check through your installation if you are licensed for workflow engine and it shows installed but no service is there. In the admin tool, do you see a workflow engine DB connection and does it test ok? Do you have a workflow engine server and does it show started?

Publié Tue, 20 Mar 2018 19:40:56 GMT par Tim Ohm

Hi Joe,

Casey, you beat me to it.  Workflow Server (along with BPS in DW 6.11+) runs the built in workflows that DW offers - UserSync, Delete, Export, etc.  Those tasks (if I recall) will eventually all transfer to BPS as each new version is released.

Workflow Engine runs the flows you build in the designer tool and can get quite complex.  So yeah...if you dont have Workflow Engine installed, those workflows won't run at all.  And I echo Casey's surprise in that you could even create and/or publish a basic WF - I thought Designer connected to Engine somewhere along the line to do publishing.  Engine is a separately licensed product.

Your third bullet refers to an option in the admin client (or somewhere else in web admin now?) - you need to turn on the cabability of a cabinet to use a workflow.  It may not show up until Engine is installed.  Another tab called "Tasks" will show up in the WebClient once everything syncs up and a user gets a task assigned to them.  Or something like that anyway.



Publié Tue, 20 Mar 2018 20:21:21 GMT par Joe Kaufman Bell Laboratories Inc No longer there

I got Workflow as a 30-day trial to play around. I assumed that everything needed would have been included, as I got it straight from DocuWare.

I guess doing a trial of Workflow is not as straightforward as it might seem. We do not have Workflow Engine Server, and as I said, the option is greyed out in the control panel.

I will speak with whomever got me the LIC file and see what is going on...

Thanks, everyone!



Joe Kaufman

Publié Tue, 20 Mar 2018 20:27:33 GMT par Tim Ohm

You may just need to run setup again and select the Engine from the component list.  That should drop it in there and you should see it light up in the DW Control Panel.  Workflow Server and Workflow Engine are 2 separate items on that checklist.  

Publié Tue, 20 Mar 2018 20:32:00 GMT par Joe Kaufman Bell Laboratories Inc No longer there

Can I run setup on a live server running production stuff? And just add a module? NOTE: I did not do ANY of the setup on the server side. The server was stood up for us by our reseller. I was in on the ground floor of configuration, but I have never done anything this in-depth on the server, and have never installed any hotfixes or updates.

I will await instruction from DocuWare sales/support that got me the LIC file with Workflow installed (I do know how to apply a LIC, at least.  *smile*)

EDIT: I found the setup files, and as you say, Workflow Engine is simply not selected. I might try to install it this evening when no one is on the system...



Joe Kaufman

Publié Tue, 20 Mar 2018 20:50:51 GMT par Phil Robson DocuWare Corporation Senior Director Professional Services, Americas

You can install a module on a hot system. No problem there. If you still have trouble please open a Support Request. My Install/ WF Team know exactly what they are doing.


Phil Robson

Publié Tue, 20 Mar 2018 20:55:55 GMT par Joe Kaufman Bell Laboratories Inc No longer there

Thanks, Phil -- I will install the WE module tonight, I have all the files ready to go and setup looks straightforward. Even if I need to bounce the server that should be OK this evening. Then tomorrow I should be able to finally see how Workflow works!




Publié Wed, 21 Mar 2018 13:11:00 GMT par Joe Kaufman Bell Laboratories Inc No longer there

Hey all,

Thanks for all the help so far -- a little progress is being made.

I installed Workflow Engine last night and it installed perfectly and was running right away, green light in the Control Panel. Still no "Tasks" button at the top of the web client. Bounced every DocuWare Service. Still no Tasks. Rebooted the whole server. Finally "Tasks" show up.

I did not see anything new in the Admin tool about turning Workflow on, so if there is something I need to do there I have no idea what it is. And folks have mentioned "testing" connections -- how do I do that? I do not see any buttons or menu options to test connections when I have connections highlighted. A database connection now exists for "Workflow Engine", and the "dwworkflowengine" database exists in SQL Server and has some Workflow data in there (the meta-data defining the workflows).

I unpublished and deleted all the workflows I had previously created. I have tried simple emailing, assigning, and tasks in the flow, everything tests fine, and yet no notifications are sent out and no tasks appear in the web client even though everything is being assigned and sent to me. I checked logs, and there are some timestamps from last night when I tried a few things, but I cannot make any new log activity appear in the logs this morning. It is like nothing is happening at all.

Straight notifications (configured in the web client config) continue to work, so the notification server is working property in terms of SMTP, etc.

So, I suppose I have to start a support ticket? Any other ideas? I got "Tasks" to show up, but that is about it...

Joe Kaufman

Publié Wed, 21 Mar 2018 13:32:49 GMT par Christopher Ure Software Support Analyst


Make sure that the correct SMTP connection is selected in the Workflow Engine Server section of the Admin Tool. Also, depending on your version there may be a hotfix for Workflow Engine notification issues. Note that even if you had installed the hotfix already, you may have to reapply them because the Workflow Engine would not have been installed when you did so.

You may also need to clear the Message Queues and restart IIS, as the task tab appearing there or not is controlled by messages in the bus. That being said, the task tab may not appear at first if you don't have a "Task" activity in your workflow: make sure you have one created, and that a workflow instance is waiting on a task step before we say there is definitely a problem.

Finally, please do open a support request if none of this works: I'm on the team that handles Workflow Engine issues, and I'd be happy to work more closely with you on answering any questions you have.

Christopher Ure

Software Support Specialist

Support Team GREEN - Americas

Publié Wed, 21 Mar 2018 13:48:13 GMT par Joe Kaufman Bell Laboratories Inc No longer there

Thanks, Christopher.

I didn't have the SMTP connection selected for the Workflow Engine connection, but now I do (and I bounced the Workflow services as well as the Notifications service). I cannot mess with IIS or the server further than that because we are up and live during the day (I assume messing with IIS will cause people to get dropped).

I have not applied any hotfixes and do not even know how to do that. So if that is required I will need support to help with that and show me how it is done.

I have gotten some errors to appear in the error log for Workflow Engine, completely cryptic ones of the type:

ServerContext::ctor: AcceptSecurityContext failed. Error Code = 2148074248 > The token supplied to the function is invalid

I will go ahead and open a support ticket.



Joe Kaufman

Publié Wed, 21 Mar 2018 15:00:40 GMT par Joe Kaufman Bell Laboratories Inc No longer there

I am not sure what happened, but after bouncing services one more time and then just not doing anything with Workflow for an hour, I removed all workflows, built a basic email workflow -- and it worked! I added an Assign To and a Task action and more notifications went out and a Task was created.

So, it looks like things are working, and ther are no recent errors in the Workflow Engine error log.

Thanks to everyone for their help -- just wish I knew what made this start working...



Joe Kaufman

Publié Wed, 21 Mar 2018 15:19:48 GMT par Christopher Ure Software Support Analyst

If I were a betting man, I'd wager that there were Workflow Engine items stuck in an IIS cache somewhere, waiting to timeout: this module relies heavily on Platform and Settings app pools to do all of the configuration, designing, and operation of the workflows, and since there were some workflows in here before you even had the service itself installed, it may have encountered some undefined behavior.

Christopher Ure

Software Support Specialist

Support Team GREEN - Americas

Publié Wed, 21 Mar 2018 15:37:12 GMT par Joe Kaufman Bell Laboratories Inc No longer there

Some sort of downstream caching/blockage makes sense to me, as even with just the Task Manager Notifications I created via the web client, changes to those notification texts would not kick in right away -- always some lag. It looks like whenever we do lots of configuration changes or additions we might want to consider bouncing all services, bouncing IIS, or just rebooting the server off-hours.

I am sure there are issues with things being "stuck", as this morning I could not make the error logs grow, then 20 minutes later I saw a bunch of errors from 20 minutes back. It takes a while for "stuckness" to work through. The errors ranged from SMTP errors (before I had properly assigned the SMTP connection) to issues about published versions of Workflows being out of sync or not being found.

Thanks again for everyone's help! We can now run Workflow through its paces to see if we need the whole thing or can get by with just Task Manager. That decision will also be based on price, obviously, as Workflow Manager is dang nifty...



Joe Kaufman

You must be signed in to post in this forum.